Results 1 to 4 of 4

Thread: metallic clink in right ear

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default metallic clink in right ear

    Hi,

    in my right ear, anything that has a "medium" sound lvl (65+ dB) causes a metallic clink in my right ear, I can hear it without HAs when yelling and sligthly when talking, and when I cover my right ear with my hand and talk. I can hear it extremly loud when I use HAs, all kinds of HAs that is.

    CIC Q90, Phonak Belang V 50 RIC + Pwer dome, Phonak Naida V 90, Oticon OPN. MY ENT said my ear drums swing normally, made a test, and that I have conductive hearing loss and that I could reach 100% comprehension in 65dB with HAs.

    I was tested with HAs and had 100% comprehension @ 65dB and 75% at a lower threshhold.

    Still I always hear that metallic clink in my right ear with HAs, which causes my psyche to drop and even though I have a rather good comprehension it could be better without that sound.

    I will make an appointment in a clinic later next week, but wanted to ask you guys for your feedback.

    Any help greatly appreciated.

    As far as I can tell that metallic clink started slightly with my tinitus 10 years ago, but the last couple of weeks it is not possible to ignore it.

    10 years ago when I needed HAs I was tested by an ENT and in a clinic and they haven't found anything specific, however I didn't mention that sound, as I was unsure of its origin(my ear, or is it the aids, I'm positive it is my ear now).
    Last edited by Gery_R; 10-28-2016 at 03:06 PM.
    Left/Right//kHz // Oticon OPN1 105dB C-Shell with support

    45/55//0.25
    60/70// 0.5
    70/70//1
    60/70//2
    60/60//3
    50/45//4
    55/50//6
    45/55//8

  2. #2

    Default

    well for starters there was a filter in my ear and it is better now since it was taken out, might still be some hardened wax somewhere...
    Left/Right//kHz // Oticon OPN1 105dB C-Shell with support

    45/55//0.25
    60/70// 0.5
    70/70//1
    60/70//2
    60/60//3
    50/45//4
    55/50//6
    45/55//8

  3. Default

    Ha! I was going to make some suggestions, but if it's just filter/wax I don't need to. I'll be interested to know whether this fully resolves.

  4. #4

    Default

    I think it has something to do with the way my old molds weren't properly fitting my canal anymore and my receivers being on their limit. The new OPN1 with the 85db receiver and new silicon (white transparent) domes don't make these sounds, or barely to a point were I would say they are gone.
    Will get c-shells and 100db once I decide which model I take, but I think I will not have that problem anymore.
    Left/Right//kHz // Oticon OPN1 105dB C-Shell with support

    45/55//0.25
    60/70// 0.5
    70/70//1
    60/70//2
    60/60//3
    50/45//4
    55/50//6
    45/55//8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •